Script Mikrotik – Enviar mail cuando ping es mayor a 200ms

Minientrada

Algo para agregar a la navaja suiza de tus script (sysadmin only): 

Hola Amigos, hace mucho que no escribo, y en este caso, me pareció que vale la pena repostear. Este script de mikrotik hecho por un chino te envia un mail cuando el ping a cierta dirección supera los 200 ms; por ejemplo, si tenemos algun enlace o cliente que queremos monitorear cuando estamos durmiendo. Si sos nerd (como yo), No dejes escapar este script, es justo para vos.

#Mikrotik Ping more than 200ms to send mail
#https://ros.ac
#By:Ali
#From:China
:local Asunto "Alarma! Monitor de ping a IP"
#Configurar la IP a monitorear
:local addre 192.168.88.1;
#Configurar el Delay maximo tolerado
:local ms 200;
:local avgRtt;
/tool flood-ping $addre count=10 do={
  :if ($sent = 10) do={
    :set avgRtt $"avg-rtt"
}}
:if ($avgRtt >= $ms) do={
#Send mail
/tool e-mail send server=<Server IP> port=25 user=<user> password=<pass> to=to@mail.com from=from@mail.com subject=$Asunto body=("Monitoreando IP:$addre\ndelay:$avgRtt ms")
:log err "La alarma ha sido enviada.";
}

Atencion, configurar las siguientes variables para que funcione correctamente el script:

:local addre 192.168.88.1; —- Aqui setear la direccion IP a la que queremos monitorear.

:local ms 200; ———- Aqui los ms. Solo cambiar el nro 200 por el valor deseado.

Email Settings: ———– No Olvides configurar server, port, user, password, to y from.
________
Primero en tech-nico.com

API MIKROTIK – Eliminar una dirección del firewall address-list

Te interesa saber como agregar una direccion IP a una lista?. Exactamente hace 1 año atrás, el armamos un ejemplo para agregar una direccion IP una lista determinada del firewall; pero nunca dijimos como eliminarla y por eso aquí esta la … Sigue leyendo

Script Mikrotik para LIMITAR dispositivos móviles con DHCP con QUEUEs Dinamicas

Bloquear / Limitar En las 3 versiones anteriores de este script podiamos “bloquear” un dispositivo movil tanto por DHCP como en el firewall del Bridge (capa 2) y en firewall capa 3. Tal vez te interesen los scripts anteriores: Version 1: … Sigue leyendo

[Actualizado] Script Mikrotik para bloquear dispositivos móviles en bridge – Muy Efectivo!

Bloqueando Celulares desde Mikrotik con Bridge filter (Efectividad 80%) NOTA: Esta es la version para filtrar por bridge, tambien podes filtrar en firewall o bloquear directamente en dhcp-server. Me toco en un colegio tener que dejar sin navegación a los celulares. En este caso … Sigue leyendo

Script Mikrotik para hacer parpadear un led del router.

Vos dirás.. y para que lo quiero?. Tal como dice el creador del script (foro Mikrotik) podría servir para señalar remotamente (al tecnico in-situ) cual es el equipo que tiene que supervisar. Lo acabo de probar y me anduvo bien. Es una pabada, pero a mi me encantó. … Sigue leyendo

Script Mikrotik para bloquear dispositivos moviles en Firewall

Bloqueando Celulares desde Mikrotik con Firewall (Efectividad 80%) NOTA: Esta es la version para filtrar por firewall, tambien podes filtrar en bridge filter o bloquear directamente en dhcp-server. Me toco en un colegio tener que dejar sin navegación a los celulares. En este … Sigue leyendo

Script Mikrotik para bloquear dispositivos móviles con DHCP

El script nacio por un comentario de nuestro colaborador “Felix Serrato” que NO vio la necesidad de bloquear los dispositivos celulares usando firewall o bridge filter. Es decir, bloquearlos directamente en los “leases” del dhcp-server y ademas que el board Mikrotik utilice menos recursos … Sigue leyendo

API MIKROTIK – Graficar trafico de interfaces en tiempo real con Highcharts y PHP

Te voy a enseñar como graficar en vivo una interfaz en particular de tu RouterOS. El ejemplo que arme en esta ocasión con las fabulosas, increíbles gráficas highcharts.com. (tal como lo pidio Cesar Maffini). Actualización: un fiel lector de nombre Alejandro … Sigue leyendo

Mikrotik Script: Marcar y controlar trafico de whatsapp por DNS

Si queremos controlar el ancho de banda de whatsapp por QoS o dropear o simplemente dejar pasar este trafico, podemos ejecutar este maravilloso script desde nuestro RouterOS, que recolecta las IP que usa esta aplicación de mensajería. Las IP que … Sigue leyendo

Script Mikrotik, mandar backup por FTP

Un usuario del foro oficial de mikrotik publico un pequeño script para enviar un backup de nuestro RouterOS por FTP. Muy bueno para automatizar nuestros routers y enviar todos los backups a una caja NAS. _________ publicado en tech-nico.com