Script Mikrotik para patear un cliente registrado con mala señal

Hola amigos, bueno, este script no es muy nuevo que digamos. Pero lo voy a postear porque le hice un agregado para mi gusto bastante importante.
En este caso, se trata de un routerboard 2011 con Wifi, y va a instalarse en un colegio. Como hay muchos celulares y netbooks, la clave del funcionamiento esta en patear cada 1 minuto los clientes que tienen muy mala señal. Y ademas, dentro del mismo script, tambien eliminaremos el «lease» del DHCP-Server.

Esto sirve para darle mucho mas rendimiento al AP, ya que si hay muchos dispositivos (celulares, tablets, netebooks de «conectar igualdad») con baja señal, el radio tiene que manejar demasiadas peticiones con re-transmicion de paquetes y llegado a un punto hasta se puede plantar.

Veran que donde dice «-86» es el tope de señal que yo configure para cuando el cliente este conectado con -87 o mas… lo saque de circulación. Ustedes pueden setear el que mas les guste.

/system script
add name=station-check-signal policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source="/interfac\
    e wireless registration-table;\r\
    \n:foreach i in=[ /interface wireless registration-table find ap=no] do={\r\
    \n   :local SIGNAL ([:pick ([get \$i signal-strength]) 0 3]);\r\
    \n   :if (\$SIGNAL < \"-86\") do={\r\
    \n           :local MAC [get \$i mac-address];\r\
    \n           :log warning (\$MAC . \" fue desconectado por baja se\F1al:  \"\
    \_.\$SIGNAL );\r\
    \n           /interface wireless registration-table remove \$i;\r\
    \n# PATEO EL DHCP DEL CLIENTE CON MALA SE\D1AL\r\
    \n          /ip dhcp-server lease;\r\
    \n           :foreach s in=[find] do={\r\
    \n                  /ip dhcp-server lease;\r\
    \n                   :if ([get \$s active-mac-address] = \$MAC) do={\r\
    \n                           :log warning (\"DHCP pateado por script de mala\
    \_se\F1al:  \" .\$MAC );\r\
    \n                           /ip dhcp-server lease remove \$s;\r\
    \n                   }\r\
    \n           }\r\
    \n           :delay 5s;\r\
    \n     }\r\
    \n}"

11 comentarios

  1. Hola Ing Pedroza, este script recorre la lista de «Wireless – Registration List» y busca clientes con baja señal de radio (Wifi) para luego patearlos. Si no tenes un RB con wireless no te sirve para nada.

  2. hola quisiera, hacer una pregunta-peticion, hay forma de que me apoyes o postees un script que:
    al detectar, un registrado en el ap «sin ip» lea la mac y la patee similar al script que tienes arriba?

    pasa que me han estado «atacando» o almenos eso parece, en dos sitios remoto el uno del otro pero con caso identico… alguien se engancha a mi ap, lo unico visible es la mac, lo pateo manualmente y se sigue enganchando…. seria bueno que aunq no detecte automaticamente la mac, pudiera agregarla manualmente al script, solo que no tengo idea de como hacerlo

  3. noobster, Seguramente tenes fijado de Mac en DHCP y no en Wireless. Cuantos clientes tenes en ese AP con problemas?

Deja un comentario