RouterOS API class 1.4 [corregida]

Esto es un update Para el que no esta familiarizado, esta es la librería que utilizamos en cada uno de los ejemplos del blog. Esta fue creada por Denis Basta, Corregido el problema de la variable “$receiveddone” que venia vacía … Sigue leyendo

Script Mikrotik – Enviar mail cuando ping es mayor a 200ms

Minientrada

Algo para agregar a la navaja suiza de tus script (sysadmin only): 

Hola Amigos, hace mucho que no escribo, y en este caso, me pareció que vale la pena repostear. Este script de mikrotik hecho por un chino te envia un mail cuando el ping a cierta dirección supera los 200 ms; por ejemplo, si tenemos algun enlace o cliente que queremos monitorear cuando estamos durmiendo. Si sos nerd (como yo), No dejes escapar este script, es justo para vos.

#Mikrotik Ping more than 200ms to send mail
#https://ros.ac
#By:Ali
#From:China
:local Asunto "Alarma! Monitor de ping a IP"
#Configurar la IP a monitorear
:local addre 192.168.88.1;
#Configurar el Delay maximo tolerado
:local ms 200;
:local avgRtt;
/tool flood-ping $addre count=10 do={
  :if ($sent = 10) do={
    :set avgRtt $"avg-rtt"
}}
:if ($avgRtt >= $ms) do={
#Send mail
/tool e-mail send server=<Server IP> port=25 user=<user> password=<pass> to=to@mail.com from=from@mail.com subject=$Asunto body=("Monitoreando IP:$addre\ndelay:$avgRtt ms")
:log err "La alarma ha sido enviada.";
}

Atencion, configurar las siguientes variables para que funcione correctamente el script:

:local addre 192.168.88.1; —- Aqui setear la direccion IP a la que queremos monitorear.

:local ms 200; ———- Aqui los ms. Solo cambiar el nro 200 por el valor deseado.

Email Settings: ———– No Olvides configurar server, port, user, password, to y from.
________
Primero en tech-nico.com

[Actualizado] Mikrotik RouterOS Address-List Whatsapp

Mikrotik RouterOS Address-List Whatsapp, Para todos aquellos que quieren ecualizar con QOS / priorizar, o bien filtrar Whatsapp, mas abajo les dejo el address-list listo para copiar y pegar en la consola de tu RouterOS. De a cuerdo al CIDR … Sigue leyendo

API MIKROTIK – Eliminar una dirección del firewall address-list

Te interesa saber como agregar una direccion IP a una lista?. Exactamente hace 1 año atrás, el armamos un ejemplo para agregar una direccion IP una lista determinada del firewall; pero nunca dijimos como eliminarla y por eso aquí esta la … Sigue leyendo

Script Mikrotik para LIMITAR dispositivos móviles con DHCP con QUEUEs Dinamicas

Bloquear / Limitar En las 3 versiones anteriores de este script podiamos “bloquear” un dispositivo movil tanto por DHCP como en el firewall del Bridge (capa 2) y en firewall capa 3. Tal vez te interesen los scripts anteriores: Version 1: … Sigue leyendo

Mikrotik [tip] Ojo con los Backups y las mac-address!

No es nada bueno, pero tiene solución: Si por alguna razón estas configurando tus equipos routerboard, puede que en algún punto necesites acelerar el proceso de configuración y decidas crear un backup de uno de los equipos para luego restaurarlo en … Sigue leyendo

Top 10 de los errores mas comunes en las configuraciones de Mikrotik RouterOS

Esta en ingles. (mas alla de su acento se entiende perfecto). Hay cosas que uno no las tiene en cuenta y son realmente muy importantes. Me gusto y quise compartirlo con mi hermandad.  

[Actualizado] Script Mikrotik para bloquear dispositivos móviles en bridge – Muy Efectivo!

Bloqueando Celulares desde Mikrotik con Bridge filter (Efectividad 80%) NOTA: Esta es la version para filtrar por bridge, tambien podes filtrar en firewall o bloquear directamente en dhcp-server. Me toco en un colegio tener que dejar sin navegación a los celulares. En este caso … Sigue leyendo

Script Mikrotik para hacer parpadear un led del router.

Vos dirás.. y para que lo quiero?. Tal como dice el creador del script (foro Mikrotik) podría servir para señalar remotamente (al tecnico in-situ) cual es el equipo que tiene que supervisar. Lo acabo de probar y me anduvo bien. Es una pabada, pero a mi me encantó. … Sigue leyendo

solucionar DNS_PROBE_FINISHED_NO_INTERNET

Para resolver este “fucking problem” tenemos que ejecutar unos comandos en la consola con privilegios de administradores; ALTERNATIVA (A): escribir los comandos manualmente. Paso 1 ) suponiendo que tenemos windows 7 u 8 vamos a inicio, y en el cuadro de busqueda … Sigue leyendo