RouterOS Script – Agregar rango de direcciones estaticas en IP Address.

Hoy me cruce con alguien que necesitaba ayuda y arme este Script como para volver con algo de actividad al blog (que de hecho lo tengo muy abandonado).

Se le da un rango de Red, luego la direccion de Inicio y la de Fin. Ademas por supuesto, la mascara de subred. Y eso es todo!.

# Por Tech-nico.com 28/01/2022
:local RED "192.168.3"
:local IPINICIO "70"
:local IPFIN  "80"
:local MASK "/32"
:local INTERFAC  "bridge_ether"
:for i from=$IPINICIO to=$IPFIN step=1 do={
     :local TEMPDIR "$RED.$i$MASK"
     /log warning "$TEMPDIR"
     /ip address add address="$TEMPDIR"  interface="$INTERFAC"
}

Sé el primero en comentar

Deja un comentario