Mikrotik Script: Buscar en PPP las IP libres no asignadas en una Clase C

Bueno, este es un script muy rebuscado que arme para listar las IP Libres de un /24. Es muy util ya que hay escasos bloques IPv4. En mi caso doy pppoe con IP fija, entonces es muy facil a veces (por error) saltearnos alguna IP y quede en desuso.

Antes de ejecutarlo hay que editar una variable que contiene nuestro rango de IP a buscar.

:global BUSCA "210.100.200";
/ip firewall address-list remove [/ip firewall address-list find list="pool_ip_libres"];
:for i from= 1 to= 254 do={
:local DIREC ($BUSCA . "." . $i);
:local VAR [:put [/ppp secret find where remote-address=$DIREC]];
:if ($VAR!="") do={
:log info (" Existe " . $DIREC );
} else={
/ip firewall address-list add list=pool_ip_libres address=$DIREC;
}
}

Luego de ejecutarlo vamos a ver que se crea una nueva lista llamada “pool_ip_libres”.
Cada vez que ejecutamos el script, se limpia primero esa lista para que no queden ips duplicadas.

Se puede mejorar, se aceptan modificaciones. El que modifique también comparta su versión asi ampliamos el post.

___________
Primero en Tech-nico.com
Nicolas

Sé el primero en comentar

Deja un comentario