Automatizacion de Backups con Mikrotik y Google Drive Parte 1

1) CONFIGURAR sNTP Client

Para que nuestro backup se ejecute correctamente lo primero es que nuestro RouterOS se mantenga siempre con la hora correcta por mas que se reinicie. Entonces pegamos esto en la consola:

/system ntp client
set enabled=yes primary-ntp=216.239.35.12

Solo aceptaremos en nuestro firewall el servidor NTP de google, ya que estos puertos suelen estar dentro de los mas atacados. Para ellos pegamos nuevamente lo siguiente en la consola:

/ip firewal filter
add action=accept chain=input comment="NTP Admitir solo a time.google.com" dst-port=123 protocol=tcp src-address=\
216.239.35.12
add action=accept chain=input dst-port=123 protocol=udp src-address=216.239.35.12
add action=drop chain=input dst-port=123 protocol=udp

2) CONFIGURAR E-MAIL

Las siguientes lineas corresponden al seteo del servicio de correo. La direccion IP es de smtp.google.com: Lo editas en tu notepad reemplazando tu contraseña y la direccion de correo y lo pegamos en la consola:

/tool e-mail
set address=172.217.192.109 from= password="TU_CONTRASEÑA_FUERTE" port=587 start-tls=yes user=\
TUMAIL@GMAIL.com

NOTA IMPORTANTE: recorda que Gmail bloquea el envio de mails de cualquier aplicacion externa (que se considera poco segura) como por ejemplo Outlook, (y cualquier otros), y por supuesto el envio de mails a traves de RouterOS. Para resolverlo loggearse con la cuenta que usaran para backups y luego hacen click en el siguiente este enlace: https://myaccount.google.com/lesssecureapps

Cambiar de NO a SI

3) PROBAR EL ENVIO DE EMAIL

Para saber si el envio es correcto probamos el envio desde consola con la siguiente linea:

/tool e-mail send to="TUMAIL@GMAIL.com" subject="soy tech-nico backups"

4) IMPORTAR SCRIPTS DE BACKUPS

A continuacion tenemos 2 scripts que debemos pegar en la consola (previo a editar la direccion de e-mail). El primer script envia el binario completo. «.backup» y el segundo script envia un export completo «.rsc». Por ahora no editen el asunto porque es importante mantener el doble slash «//». (en la parte 2 te daras cuenta del por que). Recueden que al pegar en la consola hay que presionar enter.

/system script add name=backup_binary source={/system backup save name=([/system identity get name] . "-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6]); \
/tool e-mail send to="TUMAIL@GMAIL.com" subject=([/system identity get name] . "_BACKUP//" . \
[/system clock get date]) file=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
[:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup"); :delay 10; \
/file rem [/file find name=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
[:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup")]; \
:log info ("System Backup emailed at " . [/sys cl get time] . " " . [/sys cl get date])}

Y este otro:

/system script add name=backup_export source={/export file=([/system identity get name] . "-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6]); :delay 2; \
/tool e-mail send to="TUMAIL@GMAIL.com" subject=([/system identity get name] . "_BACKUP//" . \
[/system clock get date]) file=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
[:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc"); :delay 10; \
/file rem [/file find name=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
[:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc")]; \
:log info ("System Backup emailed at " . [/sys cl get time] . " " . [/sys cl get date])}

5) AGREGARLO AL CALENDARIO DE EJECUCION

Y finalmente lo ejecutamos cada 5 dias. O como ustedes prefieran. Esto hara que se envien 2 mails. 1 con el .backup y el otro con el export .rsc.

/system scheduler
add interval=5d name=backup_binary on-event="/sys script run backup_binary" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=aug/03/2020 start-time=16:35:00
add interval=5d name=backup_export on-event="/sys script run backup_export" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=aug/03/2020 start-time=16:35:00


En la segunda parte de este post te enseñare como volcar estos mails a un Google Drive.

2 comentarios

Deja un comentario